Cadence Virtuoso CentOS 6 & CentOS 7的依赖安装清单及脚本

在实验室或者自己的虚拟机每次安装一台新的服务器,总是要安装系统和依赖的(不过可能有更科学的安装方法,直接同步安装),其实Cadence Virtuoso的依赖一共就那么几个,但是网上的很多入门教程都不够全,后面用到一些功能的时候又要去根据报错来重新安装,这里我也整理一份清单和安装脚本供大家参考,可以把这个脚本放在自己的服务器上利用curl | bash执行。

另外在这里多说一句话,如果各位的服务器和客户端采用ssh X forwarding方式,客户端是Windows系统的话(Linux肯定是没有问题的),推荐本地的X11采用Cygwin的,我已经试用了市面上几乎所有软件,开源的闭源的,都更新的不够频繁,大家都会出现卡顿和启动延迟过高(开一个新的应用窗口出来要等3s以上,很致命),用Cygwin的X11是体验最好的。

#!/usr/bin/perl

system("yum install -y ksh rsh rsh-server libXext.so.6 libXtst.so.6 libXt.so.6");
system("yum install -y libGLU.so.1 --setopt=protected_multilib=false");
system("yum install -y libelf.so.1 libXrender.so.1 libXp.so.6 libXrandr.so.2");
system("yum install -y *xorg* -");
system("yum install -y libXp libXext.so.6 ld-linux.so.2 openmotif libstdc++.so.5 libreadline.so.6 libhistory.so.6 glibc-devel");
system("yum install -y xorg-x11-fonts-75dpi.noarch xorg-x11-fonts-ISO8859-1-75dpi.noarch");
system("yum install -y xterm libreadline.so.5 readline.devel cpp");
system("yum install -y libcrypto.so.6 openssl098e.x86_64");
system("yum install -y mesa-libGLU redhat-lsb");

另外还需要安装 i686 readline-devel,直接可以

wget http://mirror.centos.org/centos/6/os/i386/Packages/compat-readline5-5.2-17.1.el6.i686.rpm
rpm -ivh compat-readline5-5.2-17.1.el6.i686.rpm --force --nodeps

以上应该是一些基本的依赖了,在CentOS 6下跑Virtuoso IC616+IC617+MMSIM151+ASSURA415+EXT应该都没有问题(不涉及到远程挂载仿真)。在CentOS 7下至少是可以启动的,全流程还没有验证过。如果有补充的希望可以在评论区指出~~

发表评论

电子邮件地址不会被公开。 必填项已用*标注